Вопрос задан 07.05.2019 в 04:00. Предмет Информатика. Спрашивает DELETED.

Для треугольника abc составьте программу для нахождения площади. (Паскаль)

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Петренко Никита.
Var a,b,c,p,s:real;
begin
read(a,b,c);
p:=(a+b+c)*0.5;
writeln(sqrt(p*(p-a)*(p-b)*(p-c)))
end.



0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке программирования Паскаль для вычисления площади треугольника по его сторонам a, b и c с использованием формулы Герона:

```pascal program CalculateTriangleArea;

var a, b, c, s, area: real;

begin // Вводим длины сторон треугольника write('Введите длину стороны a: '); readln(a); write('Введите длину стороны b: '); readln(b); write('Введите длину стороны c: '); readln(c);

// Вычисляем полупериметр треугольника s := (a + b + c) / 2;

// Вычисляем площадь по формуле Герона area := sqrt(s * (s - a) * (s - b) * (s - c));

// Выводим результат writeln('Площадь треугольника со сторонами a, b, c равна: ', area:0:2); end. ```

Обратите внимание, что данная программа предполагает, что введенные значения сторон треугольника являются допустимыми (т.е., треугольник с такими сторонами существует). В реальной программе также рекомендуется включить проверки на допустимость введенных значений.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос