 
Составьте программу в Паскаль. Седьмому классу на практике получено сдуть 1000 одуванчиков. Бригада
мальчиков первый день сдуло А одуванчиков, а бригада девочек в два раза меньше. В каждый последующий день производительность мальчиков уменьшалась на 10 %,а девочек росла на 15 % по сравнению с предыдущим. Через сколько дней классы выполнит норму Вопросительный знак сколько сделают бригада мальчиков и девочек в отдельности? 0
        0
         0
        0
    Ответы на вопрос
 
        var a,k:integer; m,d,sm,sd:real;
begin
write('A='); readln(a);
m:=a; d:=a/2;
sm:=m; sd:=d;
k:=1;
while sm+sd<1000 do
begin
m:=m*0.9; sm:=sm+m;
d:=d*1.15;sd:=sd+d;
k:=k+1;
end;
writeln('k=',k,' sm=',sm:6:2,' sd=',sd:6:2);
end.
Пример:
A=70
k=9 sm=428.81 sd=587.50
 0
                    0
                     0
                    0
                 
            Конечно, вот программа на языке Паскаль, которая решает эту задачу:
```pascal program Dandelions;
var boys, girls, totalDandelions, day: Integer; dailyDecreaseBoys, dailyIncreaseGirls: Real;
begin totalDandelions := 1000; // общее количество одуванчиков boys := totalDandelions div 3; // первоначальное количество, сдутое мальчиками girls := boys div 2; // первоначальное количество, сдутое девочками day := 1; dailyDecreaseBoys := 0.1; // ежедневное уменьшение производительности мальчиков dailyIncreaseGirls := 0.15; // ежедневное увеличение производительности девочек
while (boys + girls) < totalDandelions do begin boys := Round(boys * (1 - dailyDecreaseBoys)); // уменьшаем производительность мальчиков girls := Round(girls * (1 + dailyIncreaseGirls)); // увеличиваем производительность девочек Inc(day); // увеличиваем количество дней end;
writeln('Через ', day, ' дней бригады выполнят норму.'); writeln('Бригада мальчиков сделает ', boys, ' одуванчиков.'); writeln('Бригада девочек сделает ', girls, ' одуванчиков.'); end. ```
Эта программа симулирует процесс сдувания одуванчиков мальчиками и девочками в течение нескольких дней. Она учитывает уменьшение производительности мальчиков на 10% и увеличение производительности девочек на 15% ежедневно. Результаты выводятся в консоль: количество дней, необходимое для выполнения нормы, и количество одуванчиков, сдутых каждой бригадой отдельно.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			