
Написать программу в ABC Pascal, площадь квадрата S=p*r


Ответы на вопрос

var p,r:integer;
begin
read(p,r);
write('S = ', p*r)
end.



Вот пример программы на ABC Pascal для вычисления площади квадрата:
```pascal Program SquareArea; Uses crt; Var a, S :integer; Begin Clrscr; Writeln ('Введите сторону квадрата:'); Write ('a: '); a := 0; Readln (a); S := a * a; Writeln ('Площадь квадрата S =', S); Readln; End. ```
В этой программе мы используем переменные `a` и `S` для хранения значения стороны квадрата и его площади соответственно. После ввода значения стороны квадрата, мы вычисляем площадь квадрата, умножая значение стороны на само себя. Затем мы выводим результат на экран.
Примечание: Программа написана на ABC Pascal, а не на обычном Pascal. ABC Pascal - это диалект языка Pascal, который был разработан для обучения программированию. Он имеет некоторые отличия от стандартного Pascal, поэтому код на ABC Pascal может не работать в других средах разработки Pascal.
Источник:


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili