 
Здравствуйте...помогите мне пожалуйста! Паскаль ,надо составить программу ...Даны 5 чисел (2
целых,3 веществ.) Выбираются случайно(random) Рассчитать сумму целых чисел и результат в первую переменную. Вычислить разность вещ. чисел и результат в переменную вещ. числа... 0
        0
         0
        0
    Ответы на вопрос
 
        x,y:integer;
begin
randomize();
x:=random(-128,127);
y:=random(-128,127);
x:=x+y;
writeln(x);
r:=random()*random(-128,127);
p:=random()*random(-128,127);
q:=random()*random(-128,127);
r:=r-p-q;
writeln(r);
end.
 0
                    0
                     0
                    0
                 
            Конечно, я могу помочь вам со составлением программы на языке Паскаль для решения данной задачи.
Вот пример программы, которая решает вашу задачу:
``` program RandomNumbers;
var num1, num2, num3, num4, num5: Integer; // целые числа float1, float2, float3: Real; // вещественные числа sumIntegers: Integer; // сумма целых чисел differenceFloats: Real; // разность вещественных чисел
begin // Инициализация генератора случайных чисел Randomize;
// Генерация случайных целых чисел num1 := Random(100); num2 := Random(100); // Генерация случайных вещественных чисел float1 := Random * 100; float2 := Random * 100; float3 := Random * 100;
// Вывод сгенерированных чисел writeln('Сгенерированные числа:'); writeln('Целые числа: ', num1, ', ', num2); writeln('Вещественные числа: ', float1:0:2, ', ', float2:0:2, ', ', float3:0:2);
// Вычисление суммы целых чисел sumIntegers := num1 + num2; // Вычисление разности вещественных чисел differenceFloats := float1 - float2 - float3;
// Вывод результатов writeln('Сумма целых чисел: ', sumIntegers); writeln('Разность вещественных чисел: ', differenceFloats:0:2);
readln; end. ```
Программа начинается с инициализации генератора случайных чисел (`Randomize`). Затем генерируются случайные целые числа (`num1` и `num2`) и случайные вещественные числа (`float1`, `float2` и `float3`).
Далее, программа выводит сгенерированные числа на экран. Затем вычисляет сумму целых чисел (`sumIntegers`) и разность вещественных чисел (`differenceFloats`).
В конце программа выводит результаты на экран.
Надеюсь, это поможет вам! Если у вас возникнут вопросы, пожалуйста, сообщите.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			