Вопрос задан 05.05.2019 в 14:42. Предмет Информатика. Спрашивает Шилов Даниил.

Составьте программу, выводящую на экран все числа от -10 до 10, а также их модули. Образец вывода :

Число Модуль -10 10 -9 9 -8 8 ... ... 9 9 10 10 Язык Pascal
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Лапшов Даниил.
// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('Число Модуль');
  for var i:=-10 to 10 do
    Writeln(i:3,Abs(i):6)
end.

Пример
Число Модуль
-10    10
 -9     9
 -8     8
 -7     7
 -6     6
 -5     5
 -4     4
 -3     3
 -2     2
 -1     1
  0     0
  1     1
  2     2
  3     3
  4     4
  5     5
  6     6
  7     7
  8     8
  9     9
 10    10
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на языке Pascal для вывода чисел от -10 до 10 и их модулей

```pascal program NumbersAndModules;

var i: integer;

begin writeln('Число Модуль'); for i := -10 to 10 do begin writeln(i, ' ', abs(i)); end; end. ```

Объяснение программы: - Мы используем цикл `for` для перебора чисел от -10 до 10. - В каждой итерации цикла выводим число `i` и его модуль `abs(i)` с помощью процедуры `writeln`. - Результат программы будет выводиться на экран в формате "Число Модуль", где каждая пара чисел будет находиться на отдельной строке.

Например, вывод программы будет выглядеть следующим образом: ``` Число Модуль -10 10 -9 9 -8 8 -7 7 -6 6 -5 5 -4 4 -3 3 -2 2 -1 1 0 0 1 1 2 2 3 3 4 4 5 5 6 6 7 7 8 8 9 9 10 10 ```

Примечание: - В данной программе используется функция `abs` для вычисления модуля числа. Функция `abs` возвращает абсолютное значение числа, то есть его модуль. - Программа написана на языке Pascal, однако вы можете адаптировать ее для использования на других языках программирования, заменив синтаксис языка Pascal на соответствующий синтаксис выбранного вами языка.

Надеюсь, это поможет! Если у вас возникнут еще вопросы, не стесняйтесь задавать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос