Вопрос задан 14.05.2018 в 06:11.
Предмет Информатика.
Спрашивает Макарова Катя.
ПОМОГИТЕ СРОЧНО!!! Ниже написана программа. Получив на вход число x, эта программа печатает два
числа, a и b. Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 9. ПОЖАЛУЙСТА С РЕШЕНИЕМ! var x, a, b : integer; begin readln (x); a := 0; b := 1; while x > 0 do begin a := a + 1; b := b * (x mod 5); x := x div 5; end; writeln (a); write (b); end.Ответы на вопрос
Отвечает Гордеев Никита.
//Я снова предстаю в ипостаси гуманитария, не желающего ничего считать
//Сделаем так, чтобы код сам выдавал нам ответы
var x,a,b,m:integer;
begin
for m:=1 to 10000 do //m- тот же x, сохранённый для цикла
begin;
x:=m;
a := 0;
b := 1;
while x > 0 do begin
a := a + 1;
b := b * (x mod 5);
x := x div 5;
end;
if (a=3) and (b=9) then writeln(m);
//если программа должна вернуть подходящие нам значения, возвращаем x
end;
end.
Вывод программы:
43
83
91
Ответ:91
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
