Программа на с++ Дан массив, состоящий из целых чисел. Напишите программу, которая подсчитает
количество элементов массива, больших предыдущего (элемента с предыдущим номером). Входные данные Сначала задано число N — количество элементов в массиве (1N10000). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел. Выходные данные Необходимо вывести единственное число - количество элементов массива, больших предыдущего. Примеры входные данные 5 1 2 3 4 5 выходные данные 4Ответы на вопрос
using namespace std;
int main() {
int n;
cin >> n;
int *arr = new int[n];
for (int i = 0; i < n; i++) {
cin >> arr[i];
}
int counter=0;
for (int i = 1; i < n; i++) {
if (arr[i] > arr[i-1]) {
counter++;
}
}
cout << counter;
return 0;
}
Вот пример программы на языке C++ для подсчета количества элементов массива, которые больше предыдущего элемента:
```cpp
#include
int main() { int N; cin >> N; // Вводим количество элементов массива
int arr[N]; for (int i = 0; i < N; i++) { cin >> arr[i]; // Вводим элементы массива }
int count = 0; for (int i = 1; i < N; i++) { if (arr[i] > arr[i-1]) { count++; // Увеличиваем счетчик, если текущий элемент больше предыдущего } }
cout << count << endl; // Выводим количество элементов, больших предыдущего
return 0; } ```
Пример входных данных: ``` 5 1 2 3 4 5 ```
Пример выходных данных: ``` 4 ```
В данном примере программа считывает число N - количество элементов в массиве, а затем считывает N чисел - элементы массива. Затем программа проходит по массиву и сравнивает каждый элемент с предыдущим. Если текущий элемент больше предыдущего, то увеличивает счетчик. В конце программа выводит значение счетчика - количество элементов, больших предыдущего.
Примечание: В данном примере не проводится проверка на корректность ввода данных, поэтому в реальной программе следует добавить соответствующие проверки.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
