// Решение нужно на языке программирования C++. Задан номер мобильного телефона. Определить, какие
цифры отсутствуют в этом номере. Входные данные: в единственной строке задан номер мобильного телефона. Выходные данные: в первой строке вывести количество отсутствующих в номере цифр. Во второй строке в порядке возрастания вывести отсутствующие цифры, разделенные пробелом.Ответы на вопрос
#include <set>
#include <iterator>
using namespace std;
int main()
{
string s;
cin >> s;
set<char> mySet;
set<char>::iterator it;
for(char i='0'; i<='9'; i++) mySet.insert(i);
for(int i=0; i<s.length(); i++) mySet.erase(s[i]);
cout << mySet.size() << endl;
for(it=mySet.begin(); it!=mySet.end(); ++it)
cout<<*it<<" ";
return 0;
}
Пример:
74959741926
3
0 3 8
Для решения данной задачи на языке программирования C++ можно использовать следующий алгоритм:
1. Считать номер мобильного телефона из входной строки. 2. Создать массив размером 10 (по количеству цифр) и инициализировать его нулями. 3. Пройтись по каждой цифре номера телефона и увеличить соответствующий элемент массива. 4. Пройтись по каждому элементу массива и если значение равно нулю, то данная цифра отсутствует в номере телефона. 5. Вывести количество отсутствующих цифр в первой строке. 6. Вывести отсутствующие цифры во второй строке, разделяя их пробелом.
Пример реализации на C++:
```cpp
#include
int main() { std::string phoneNumber; std::cin >> phoneNumber;
std::vector
for (char digit : phoneNumber) { if (isdigit(digit)) { int index = digit - '0'; digits[index]++; } }
int missingCount = 0; std::string missingDigits;
for (int i = 0; i < 10; i++) { if (digits[i] == 0) { missingCount++; missingDigits += std::to_string(i) + " "; } }
std::cout << missingCount << std::endl; std::cout << missingDigits << std::endl;
return 0; } ```
Пример работы программы:
Входные данные: ``` 1234567890 ```
Выходные данные: ``` 0 ```
В данном примере все цифры от 0 до 9 присутствуют в номере телефона, поэтому количество отсутствующих цифр равно 0.
Входные данные: ``` 9876543210 ```
Выходные данные: ``` 0 ```
В данном примере также все цифры от 0 до 9 присутствуют в номере телефона.
Входные данные: ``` 123456 ```
Выходные данные: ``` 4 0 7 8 9 ```
В данном примере в номере телефона отсутствуют цифры 0, 7, 8 и 9.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
