Вопрос задан 03.05.2019 в 04:35. Предмет Информатика. Спрашивает Билей-Кейда Валерия.

Написать программу: с клавиатуры вводится четырехзначное целое число. Вывести на экран сообщение о

соотношении суммы крайних цифр и суммы средних цифр этого числа (меньше, больше или равны).
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Калакустова Варя.
Var a,a1,a2,a3,a4,s1,s2:integer;
begin
readln(a);
a1:=a div 1000;
a2:=a div 100 mod 10;
a3:=a mod 100 div 10;
a4:=a mod 10;
s1:=a1+a4; s2:=a2+a3;
if s1>s2 then writeln(s1,' > ',s2)
 else if s1<s2 then writeln(s1,' < ',s2)
  else writeln(s1,' = ',s2);
end.

Пример:
4382
6 < 11
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа для сравнения суммы крайних и средних цифр четырехзначного числа

Чтобы написать программу, которая будет выводить сообщение о соотношении суммы крайних и суммы средних цифр четырехзначного числа, нужно выполнить следующие шаги:

1. Запросить у пользователя ввод четырехзначного целого числа с клавиатуры. 2. Разделить это число на отдельные цифры. 3. Вычислить сумму крайних цифр (первой и последней) и сумму средних цифр (второй и третьей). 4. Сравнить полученные суммы и вывести соответствующее сообщение на экран.

Вот пример программы на языке Pascal, который выполняет описанные шаги:

```pascal program SumComparison;

var number, firstDigit, lastDigit, middleDigitsSum, extremesSum: integer;

begin // Запрос ввода числа write('Введите четырехзначное целое число: '); readln(number);

// Вычисление крайних цифр и суммы средних цифр firstDigit := number div 1000; lastDigit := number mod 10; middleDigitsSum := (number div 10) mod 100; extremesSum := firstDigit + lastDigit;

// Сравнение сумм и вывод сообщения if extremesSum < middleDigitsSum then writeln('Сумма крайних цифр меньше суммы средних цифр.') else if extremesSum > middleDigitsSum then writeln('Сумма крайних цифр больше суммы средних цифр.') else writeln('Сумма крайних цифр равна сумме средних цифр.');

readln; end. ```

Программа запрашивает у пользователя ввод четырехзначного числа, вычисляет сумму крайних и сумму средних цифр, сравнивает их и выводит соответствующее сообщение на экран.

Примечание: В данном примере использован язык программирования Pascal. Вы можете использовать другой язык программирования по своему выбору, принцип работы программы будет аналогичным.

Источники: -(https://www.visualstudio.com)

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос