Вопрос задан 03.05.2019 в 03:53. Предмет Информатика. Спрашивает Тыщенко Ксения.

Помогите составить программу. Задание: На компьютер поступают результаты соревнований по плаванию

для трех спортсменов. Составить программу так, чтобы ПК сам выбирал лучший результат. Буду благодарна!
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Гололобов Игорь.
Var
a, b, c, min: longint;
begin
readln(a, b, c);
min:=a;
if b < min then min:=b;
if c < min then min:=c;
writeln(min);
readln;
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Составление программы для выбора лучшего результата

Для решения данной задачи можно написать программу, которая будет сравнивать результаты трех спортсменов и выбирать лучший из них. Вот пример программы на Python, которая может решить данную задачу:

```python # Результаты спортсменов results = [34, 0, 25]

# Выбор лучшего результата best_result = max(results)

# Вывод результата print("Лучший результат: ", best_result) ```

В этом примере программа создает список `results`, содержащий результаты трех спортсменов. Затем она использует функцию `max()` для выбора наивысшего результата из списка и выводит его на экран.

Примечание: Представленный пример программы написан на языке Python и предполагает, что результаты спортсменов уже известны и хранятся в списке `results`.

Если у вас есть предпочтения относительно языка программирования или других деталей, пожалуйста, уточните, и я могу адаптировать программу под ваши требования.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос