В ПАСКАЛЕ!!!!!!!!!!!!! В массив A[n] занесены натуральные числа. Найти сумму тех элементов, которые
кратны данному K (A[i] mod k ) = 0Ответы на вопрос
N = 33;
Var
A:array[1..N] of integer;
i,K:integer;
S:real;
Begin
Write('K = ');ReadLn(K);
S:=0;
For i:= 1 to N do
Begin
A[i]:=random(100)+1;
Write(A[i],' ');
if A[i] mod K = 0 then S:=S+A[i];
End;
WriteLn;
Write('S = ',S);
End.
В Паскале можно написать программу, которая будет находить сумму элементов массива A, кратных заданному числу K. Вот пример кода на языке Pascal:
```pascal program SumOfMultiples; const n = 10; // размер массива A K = 3; // заданное число K var A: array[1..n] of Integer; i, sum: Integer; begin // Заполнение массива A натуральными числами for i := 1 to n do A[i] := i; sum := 0; // переменная для хранения суммы // Нахождение суммы элементов, кратных K for i := 1 to n do begin if A[i] mod K = 0 then sum := sum + A[i]; end; // Вывод результата writeln('Сумма элементов, кратных ', K, ': ', sum); end. ```
В этом примере мы объявляем массив `A` размером `n` и заполняем его натуральными числами. Затем мы итерируемся по элементам массива и проверяем, делится ли текущий элемент на `K` без остатка. Если да, то добавляем его к сумме `sum`. В конце программы выводим результат - сумму элементов, кратных `K`.
Обратите внимание, что в этом примере размер массива `A` равен 10, а число `K` равно 3. Вы можете изменить эти значения в соответствии с вашими потребностями.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
