Дана матрица А. Написать программу определения количества положительных и отрицательных элементов
матрицы. Язык Visual Basic.Ответы на вопрос
Dim myArray(3,3) as Integer
Dim count_pos as Integer
Dim cout_neg as Integer
Dim i as Integer
Dim j as Integer
count pos = 0, count_neg = 0
For i = 0 to 3
For j = 0 to 3
If (myArray(i,j) > 0) Then
count_pos = count_pos+1
Else if (myArray(i,j) < 0) Then
count_neg = count_neg+1
Else
End If
Next j
Next i
MsgBox("Положительных чисел " & count_pos & " ,а отрицательных " & count_neg);
EndSub
Для решения данной задачи на определение количества положительных и отрицательных элементов матрицы в языке Visual Basic, вам потребуется использовать вложенные циклы для обхода каждого элемента матрицы и проверки его значения.
Вот пример программы на Visual Basic, которая решает данную задачу:
```vb Sub CountPositiveAndNegativeElements(matrix As Integer(,)) Dim positiveCount As Integer = 0 Dim negativeCount As Integer = 0
For i As Integer = 0 To matrix.GetLength(0) - 1 For j As Integer = 0 To matrix.GetLength(1) - 1 If matrix(i, j) > 0 Then positiveCount += 1 ElseIf matrix(i, j) < 0 Then negativeCount += 1 End If Next Next
Console.WriteLine("Количество положительных элементов: " & positiveCount) Console.WriteLine("Количество отрицательных элементов: " & negativeCount) End Sub ```
Вы можете вызвать эту процедуру, передав матрицу в качестве аргумента. Например, если у вас есть матрица `A` размером 3x3, вы можете вызвать эту процедуру следующим образом:
```vb Dim A(2, 2) As Integer A(0, 0) = 1 A(0, 1) = -2 A(0, 2) = 3 A(1, 0) = -4 A(1, 1) = 5 A(1, 2) = -6 A(2, 0) = 7 A(2, 1) = -8 A(2, 2) = 9
CountPositiveAndNegativeElements(A) ```
Этот код выведет количество положительных и отрицательных элементов в матрице `A`.
Примечание: В приведенном коде предполагается, что вы используете консольное приложение Visual Basic. Если вы используете другой тип приложения, такой как Windows Forms или WPF, вам нужно будет изменить способ вывода результатов (например, использовать метки или текстовые поля вместо `Console.WriteLine`).
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
