Вопрос задан 02.05.2019 в 12:47. Предмет Информатика. Спрашивает Сидорова Екатерина.

Написать программу в Паскале, массив который меняет 5 и 3 строку.

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Карбулов Виталий.
Const n=6; m=4;
var 
a:array[1..n,1..m] of integer;
i,j,c:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 for j:=1 to m do
  begin
  a[i,j]:=random(50);
  write(a[i,j]:4);
  end;
  writeln;
 end;
for j:=1 to m do
 begin
 c:=a[3,j]; a[3,j]:=a[5,j]; a[5,j]:=c;
 end;
writeln('Полученный массив:');
for i:=1 to n do
 begin
 for j:=1 to m do write(a[i,j]:4);
 writeln;
 end;
end.

Пример:
Исходный массив:
  25   4  33  17
  19  23  42   9
  36  40   1  48
  21  44  13  18
  38  29   8   7
  24  13   5  13
Полученный массив:
  25   4  33  17
  19  23  42   9
  38  29   8   7
  21  44  13  18
  36  40   1  48
  24  13   5  13
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на Паскале для замены 5 и 3 строки в массиве

Вот пример программы на языке Паскаль, которая меняет местами 5-ую и 3-ую строки в массиве:

```pascal program SwapRows; const numRows = 5; // Количество строк в массиве numCols = 3; // Количество столбцов в массиве var arr: array[1..numRows, 1..numCols] of Integer; // Массив tempRow: array[1..numCols] of Integer; // Временный массив для хранения строки i: Integer; // Счетчик

begin // Заполняем массив случайными значениями for i := 1 to numRows do begin arr[i, 1] := Random(100); // Генерируем случайное число от 0 до 99 arr[i, 2] := Random(100); arr[i, 3] := Random(100); end;

// Выводим исходный массив writeln('Исходный массив:'); for i := 1 to numRows do writeln(arr[i, 1], ' ', arr[i, 2], ' ', arr[i, 3]);

// Меняем местами 5-ую и 3-ую строки for i := 1 to numCols do begin tempRow[i] := arr[5, i]; arr[5, i] := arr[3, i]; arr[3, i] := tempRow[i]; end;

// Выводим измененный массив writeln('Массив после замены строк:'); for i := 1 to numRows do writeln(arr[i, 1], ' ', arr[i, 2], ' ', arr[i, 3]); end. ```

В этой программе мы используем двумерный массив `arr`, состоящий из 5 строк и 3 столбцов. Сначала мы заполняем массив случайными значениями. Затем мы меняем местами 5-ую и 3-ую строки, используя временный массив `tempRow` для хранения строки, которую мы хотим поменять. Наконец, мы выводим исходный массив и массив после замены строк.

Примечание: В этой программе используется функция `Random`, которая генерирует случайное число. Чтобы использовать эту функцию, вам может потребоваться подключить модуль `CRT` и вызвать процедуру `Randomize` в начале программы.

Надеюсь, это поможет! Если у вас возникнут еще вопросы, не стесняйтесь задавать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос