Помогите написать программу на Pascal Из трехзначного числа X вычли его последнюю цифру. Когда
результат разделили на 10, а к частному слева приписали последнюю цифру числа X. То получилось число N. По заданному N найти число X (значение N вводится с клавиатуры, 10<=N<=999 , и при этом число десятков в N не равно нулю).Ответы на вопрос
var
N: integer;
begin
readln(N);
write(10 * (N mod 100) + (N div 100))
end.
Программа на Pascal для нахождения числа X по заданному N
Для решения данной задачи на языке Pascal, мы можем использовать следующий алгоритм:
1. Считываем значение N с клавиатуры. 2. Инициализируем переменные X, lastDigit и quotient. 3. Присваиваем переменной X значение N. 4. Вычисляем последнюю цифру числа X и сохраняем ее в переменную lastDigit. 5. Вычисляем частное от деления числа X на 10 и сохраняем его в переменную quotient. 6. Слева от частного приписываем последнюю цифру числа X, чтобы получить число N. 7. Сравниваем полученное число N с заданным значением N. Если они равны, выводим число X. Если нет, выводим сообщение о том, что число X не найдено.
Вот пример программы на Pascal, реализующей данный алгоритм:
```pascal program FindX;
var N, X, lastDigit, quotient: Integer;
begin // Шаг 1: Считываем значение N с клавиатуры Write('Введите значение N (10<=N<=999, число десятков в N не равно нулю): '); Readln(N);
// Шаг 2: Инициализируем переменные X := 100; // Начальное значение X
// Шаги 3-6: Вычисляем число X по заданн
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
