ПОМОГИТЕ С ИНФОРМАТИКОЙ (ПАСКАЛЬ) Написать на языке Тurbo Pascal программу для следующей задачи:
Ввести три двухзначных числа целого типа. Найти среднее арифметическое этих чисел и вывести его с использованием формата по умолчанию и явно заданного формата. Vara,b,c:integer; D:real; Begin WriteLn(‘Vvedite 4,5,6’); ReadLn(4,5,6); 5:=(4+5+6)/3; WriteLn(‘d= ‘,5); WriteLn(‘d= ‘,5:5:2); End. Исходные данные а=4 b=5 c=6 Результат работы программы:_______Ответы на вопрос
d:real;
Begin
WriteLn('Vvedite 3 числа');
ReadLn(a,b,c);
d:=(a+b+c)/3;
WriteLn('d= ',d);
WriteLn('d= ',d:5:2);
End.
Пример:
Vvedite 3 числа
4 5 6
d= 5
d= 5.00
Написание программы на языке Turbo Pascal
Для решения данной задачи на языке Turbo Pascal, нам необходимо написать программу, которая вводит три двузначных числа, находит их среднее арифметическое и выводит его с использованием формата по умолчанию и явно заданного формата.
Вот пример программы на языке Turbo Pascal, решающей данную задачу:
```pascal program AverageCalculation;
var a, b, c: integer; average: real;
begin writeln('Введите три двузначных числа:'); readln(a, b, c);
average := (a + b + c) / 3;
writeln('Среднее арифметическое: ', average); writeln('Среднее арифметическое с явно заданным форматом: ', average:5:2); end. ```
Объяснение программы
- `program AverageCalculation;` - объявляет начало программы с именем "AverageCalculation". - `var a, b, c: integer; average: real;` - объявляет переменные a, b, c как целочисленные и average как вещественное число. - `begin` - начало основной части программы. - `writeln('Введите три двузначных числа:'); readln(a, b, c);` - выводит текст "Введите три двузначных числа:" и считывает три значения в переменные a, b, c. - `average := (a + b + c) / 3;` - вычисляет среднее арифметическое трех чисел. - `writeln('Среднее арифметическое: ', average);` - выводит среднее арифметическое с использованием формата по умолчанию. - `writeln('Среднее арифметическое с явно заданным форматом: ', average:5:2);` - выводит среднее арифметическое с явно заданным форматом (5 знаков перед запятой и 2 знака после запятой). - `end.` - завершение основной части программы.
Результат работы программы
После ввода значений для a, b, c программа выведет среднее арифметическое этих чисел и среднее арифметическое с явно заданным форматом.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
