Написать программу которая определяет число полиндромПаскаль(ну или хотя бы идейку подкиньте)
Ответы на вопрос
Uses crt;
var s: string;
i,f: byte;
begin
clrscr;
write('String: ');
readln(s);
f := 0;
for i := 1 to length(s) div 2 do if s[i] <> s[length(s)-i+1] then begin writeln('No palindrome');
f := 1;
break
end;
if f = 0 then write('Palindrome');
readln
end.
Конечно! Я могу помочь вам написать программу для определения числа палиндрома в языке программирования Паскаль. Палиндром - это число или текст, которые одинаково читаются в обоих направлениях. Например, 121 или "шалаш" являются палиндромами.
Вот пример программы на Паскале, которая определяет, является ли заданное число палиндромом:
```pascal program PalindromeCheck;
uses SysUtils;
function IsPalindrome(num: Integer): Boolean; var original, reverse: String; begin original := IntToStr(num); reverse := ''; // Reverse the original number for var i := Length(original) downto 1 do reverse := reverse + original[i]; // Check if the original and reversed numbers are the same Result := original = reverse; end;
var number: Integer; begin // Read the number from the user Write('Enter a number: '); ReadLn(number); // Check if the number is a palindrome if IsPalindrome(number) then WriteLn('The number is a palindrome.') else WriteLn('The number is not a palindrome.'); end. ```
В этом примере мы определяем функцию `IsPalindrome`, которая принимает число в качестве аргумента и возвращает `True`, если число является палиндромом, и `False` в противном случае. Внутри этой функции мы преобразуем число в строку, затем переворачиваем его и сравниваем с оригинальной строкой.
Затем мы считываем число от пользователя и вызываем функцию `IsPalindrome` для проверки. Результат выводится на экран.
Надеюсь, это поможет вам начать работу со своей программой на Паскале для определения числа палиндрома. Если у вас возникнут дополнительные вопросы, не стесняйтесь задавать их!
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
