Напишите программу, которая принимает число, а на выходе возвращает ноль, если число четное и само
число, если оно нечетное. PascalОтветы на вопрос
Вот пример программы на языке Pascal, которая принимает число и возвращает ноль, если число четное, и само число, если оно нечетное:
```pascal program CheckEvenOdd; var number: integer; begin writeln('Введите число:'); readln(number); if number mod 2 = 0 then writeln('Число ', number, ' является четным.') else writeln('Число ', number, ' является нечетным.'); end. ```
В этой программе мы сначала запрашиваем у пользователя ввод числа. Затем мы проверяем, делится ли число на 2 без остатка с помощью оператора `mod`. Если остаток от деления равен нулю, то число четное, и мы выводим сообщение об этом. В противном случае, число нечетное, и мы также выводим сообщение об этом.
Надеюсь, это поможет! Если у вас возникнут еще вопросы, не стесняйтесь задавать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
