Вопрос задан 29.04.2019 в 14:53.
Предмет Информатика.
Спрашивает Арыстанбаев Диас.
Составьте программу которая определяет сколько слагаемых должно быть в сумме 1+2+3+4+..., чтобы
сумма оказалась: больше заданного числа nОтветы на вопрос
Отвечает Масейко Максим.
Var
n,i : Integer;
Begin
Readln(n);
i:=1;
While (i+1)*i div 2<=n do Inc(i);
Writeln(i);
end.
n,i : Integer;
Begin
Readln(n);
i:=1;
While (i+1)*i div 2<=n do Inc(i);
Writeln(i);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Для решения этой задачи мы можем написать программу на Python. Программа будет искать количество слагаемых, необходимых для того, чтобы сумма последовательности была больше заданного числа n.
Давайте начнем с написания такой программы.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
