
Помогите пожалуйста! Программа с++ (хотябы половину) В программе определить массив структур.
Каждый элемент массива хранит информацию об успеваемости учеников школы: Номер, Фамилия, Имя, Отчество, возраст, класс, оценка по математике, оценка по русскому языку, оценка по информатике. Заполнить массив структур с клавиатуры. В программе: 1) посчитать средний возраст учеников из 5Б класса; 2) посчитать количество учеников с тройками по любому из предметов; 3) найти всю информацию об учениках, имеющих пятёрки по всем предметам; 4) найти информацию об учениках (ФИО, класс, оценки), фамилии которых начинаются на букву «К».

Ответы на вопрос




Для решения данной задачи вам потребуется написать программу на языке C++. В программе вы будете использовать массив структур для хранения информации об успеваемости учеников школы.
Определение структуры
Сначала нужно определить структуру, которая будет хранить информацию об ученике. В данном случае, структура будет содержать следующие поля: номер, фамилия, имя, отчество, возраст, класс, оценка по математике, оценка по русскому языку и оценка по информатике. Вот пример определения структуры:```cpp struct Student { int number; std::string lastName; std::string firstName; std::string patronymic; int age; std::string grade; int mathGrade; int russianGrade; int computerScienceGrade; }; ```
Заполнение массива структур с клавиатуры
Далее, вы можете написать код для заполнения массива структур с клавиатуры. Вам потребуется объявить массив структур и использовать цикл для заполнения каждого элемента массива. Вот пример кода:```cpp const int ARRAY_SIZE = 10; // Здесь можно указать нужный размер массива
Student students[ARRAY_SIZE];
for (int i = 0; i < ARRAY_SIZE; i++) { std::cout << "Введите информацию об ученике " << i + 1 << ":" << std::endl; std::cout << "Номер: "; std::cin >> students[i].number; std::cout << "Фамилия: "; std::cin >> students[i].lastName; std::cout << "Имя: "; std::cin >> students[i].firstName; std::cout << "Отчество: "; std::cin >> students[i].patronymic; std::cout << "Возраст: "; std::cin >> students[i].age; std::cout << "Класс: "; std::cin >> students[i].grade; std::cout << "Оценка по математике: "; std::cin >> students[i].mathGrade; std::cout << "Оценка по русскому языку: "; std::cin >> students[i].russianGrade; std::cout << "Оценка по информатике: "; std::cin >> students[i].computerScienceGrade; } ```
Решение задач
Теперь, когда у вас есть массив структур с заполненными данными об учениках, вы можете решить задачи, описанные в вашем вопросе.1) Посчитать средний возраст учеников из 5Б класса: ```cpp int sumAge = 0; int count = 0;
for (int i = 0; i < ARRAY_SIZE; i++) { if (students[i].grade == "5Б") { sumAge += students[i].age; count++; } }
double averageAge = static_cast
std::cout << "Средний возраст учеников из 5Б класса: " << averageAge << std::endl; ```
2) Посчитать количество учеников с тройками по любому из предметов: ```cpp int countStudentsWithThrees = 0;
for (int i = 0; i < ARRAY_SIZE; i++) { if (students[i].mathGrade == 3 || students[i].russianGrade == 3 || students[i].computerScienceGrade == 3) { countStudentsWithThrees++; } }
std::cout << "Количество учеников с тройками по любому из предметов: " << countStudentsWithThrees << std::endl; ```
3) Найти всю информацию об учениках, имеющих пятёрки по всем предметам: ```cpp for (int i = 0; i < ARRAY_SIZE; i++) { if (students[i].mathGrade == 5 && students[i].russianGrade == 5 && students[i].computerScienceGrade == 5) { std::cout << "Информация об ученике с пятёрками по всем предметам:" << std


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili