Вопрос задан 28.04.2019 в 17:06. Предмет Информатика. Спрашивает Galstyan Vahagn.

Написать программу вычисления и вывода на экран периметра и площади прямоугольника.Помогите

пожалуйста очень нужно!За ранее спасибо!
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Федів Антон.
При условии, что стороны прямоугольника вводятся с клавиатуры и являются целыми числами:

program p_s;
var
  a,b,p,s:integer;
begin
  write('введите сторону a: ');
  readln(a);
  write('введите сторону b: ');
  readln(b);
  p:=(a*2)+(b*2);
  writeln('периметр: ', p);
  s:=a*b;
  writeln('площадь: ', s);
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа для вычисления и вывода на экран периметра и площади прямоугольника

Для написания программы, которая будет вычислять и выводить на экран периметр и площадь прямоугольника, можно использовать язык программирования C. Вот пример программы:

```c #include

int main() { float length, width, perimeter, area;

// Ввод длины и ширины прямоугольника printf("Введите длину прямоугольника: "); scanf("%f", &length); printf("Введите ширину прямоугольника: "); scanf("%f", &width);

// Вычисление периметра и площади прямоугольника perimeter = 2 * (length + width); area = length * width;

// Вывод на экран периметра и площади прямоугольника printf("Периметр прямоугольника: %.2f\n", perimeter); printf("Площадь прямоугольника: %.2f\n", area);

return 0; } ```

В этой программе мы используем переменные `length` (длина), `width` (ширина), `perimeter` (периметр) и `area` (площадь) для хранения соответствующих значений. Пользователю предлагается ввести длину и ширину прямоугольника, после чего программа вычисляет периметр и площадь и выводит их на экран.

Примечание: В данном примере используется тип данных `float` для переменных `length`, `width`, `perimeter` и `area`, чтобы иметь возможность работать с числами с плавающей запятой. Если вам нужны только целочисленные значения, вы можете использовать тип данных `int` вместо `float`.

Надеюсь, эта программа поможет вам вычислить и вывести на экран периметр и площадь прямоугольника. Если у вас возникнут дополнительные вопросы, пожалуйста, не стесняйтесь задавать их!

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос