составить программу на Pascal ABC. Составить программу которая вычисляет сумму всех нечетных и
кол-во четных чисел от 10 до 99Ответы на вопрос
Program n1;
Uses CRT;
Const n=7;
Var i,k,s: integer;
begin
for i:=10 to 99 do
if i mod 2=1 then s:=s+i
else k:=k+1;
writeln('Summa nechetnyx =',s,' a chetnih chisel ',k);
readln
end.
Программа на Pascal ABC для вычисления суммы нечетных чисел и количества четных чисел от 10 до 99
Вот пример программы на Pascal ABC, которая вычисляет сумму всех нечетных чисел и количество четных чисел в диапазоне от 10 до 99:
```pascal program SumAndCount;
var number, sum, count: integer;
begin sum := 0; count := 0;
for number := 10 to 99 do begin if number mod 2 = 1 then begin sum := sum + number; end else begin count := count + 1; end; end;
writeln('Сумма всех нечетных чисел: ', sum); writeln('Количество четных чисел: ', count); end. ```
В этой программе мы используем переменные `number`, `sum` и `count`. Переменная `number` используется для перебора чисел в диапазоне от 10 до 99. Переменная `sum` используется для хранения суммы всех нечетных чисел, а переменная `count` используется для подсчета количества четных чисел.
Мы используем цикл `for` для перебора чисел от 10 до 99. Внутри цикла мы проверяем, является ли число нечетным с помощью оператора `mod`. Если число нечетное, мы добавляем его к сумме `sum`. Если число четное, мы увеличиваем счетчик `count` на 1.
В конце программы мы выводим сумму всех нечетных чисел и количество четных чисел с помощью процедуры `writeln`.
Примечание: Программа была написана на основе моего знания языка Pascal ABC. Если у вас возникнут проблемы с выполнением программы или у вас возникнут вопросы, не стесняйтесь задавать их. Я всегда готов помочь!
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
