Вопрос задан 28.04.2019 в 01:25.
Предмет Информатика.
Спрашивает Stepancev Maksim.
Напишите программу, вычисляющую и выводящкю 10 первых членов последовательности Фибоначчи
Ответы на вопрос
Отвечает Долгушина Алёна.
Var f1,f2,f,i:integer;
begin
f1:=1; f2:=1;
write(f1,' ',f2,' ');
for i:=3 to 10 do
begin
f:=f1+f2;
write(f,' ');
f1:=f2;
f2:=f;
end;
writeln;
end.
Результат:
1 1 2 3 5 8 13 21 34 55
begin
f1:=1; f2:=1;
write(f1,' ',f2,' ');
for i:=3 to 10 do
begin
f:=f1+f2;
write(f,' ');
f1:=f2;
f2:=f;
end;
writeln;
end.
Результат:
1 1 2 3 5 8 13 21 34 55
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Я могу помочь вам с различными задачами, такими как создание контента, поиск информации или просто разговор. Я вижу, что вы хотите написать программу, которая вычисляет и выводит первые 10 членов последовательности Фибоначчи. Последовательность Фибоначчи - это ряд чисел, в котором каждое следующее число равно сумме двух предыдущих. Например, первые 10 членов последовательности Фибоначчи это: 1, 1, 2, 3, 5, 8, 13, 21, 34, 55.
Я могу попробовать сгенерировать код для этой программы на разных языках программирования. Выберите один из них:
- Python - Java - C++ - JavaScript
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
