Вопрос задан 27.04.2019 в 23:48. Предмет Информатика. Спрашивает Кислицин Сергей.

ПАСКАЛЬ . Составьте программу, которая выводит на экран все двузначные числа сумма цифр которых

делится на 3 и 4
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Гапон Мария.
Program n;
var res, i;
begin
for i:=11 to 99 do
if (((i div 10) + (i mod 10)) mod 3 = 0) and (((i div 10) + (i mod 10)) mod 4 = 0) then write(i,' ');
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на языке Паскаль для вывода двузначных чисел, сумма цифр которых делится на 3 и 4

Для решения данной задачи на языке Паскаль можно использовать циклы и условные операторы. Вот пример программы, которая выводит на экран все двузначные числа, сумма цифр которых делится на 3 и 4:

```pascal program TwoDigitNumbers;

var number: integer; digit1, digit2, sum: integer;

begin for number := 10 to 99 do begin digit1 := number div 10; // первая цифра числа digit2 := number mod 10; // вторая цифра числа sum := digit1 + digit2; // сумма цифр числа

if (sum mod 3 = 0) and (sum mod 4 = 0) then begin writeln(number); end; end; end. ```

В данной программе мы используем переменные `number`, `digit1`, `digit2` и `sum`. Цикл `for` перебирает все двузначные числа от 10 до 99. Внутри цикла мы разделяем число на две цифры (`digit1` и `digit2`) с помощью операций деления на 10 и взятия остатка от деления на 10. Затем мы вычисляем сумму цифр числа и проверяем, делится ли эта сумма и на 3, и на 4 с помощью условного оператора `if`. Если условие выполняется, то число выводится на экран с помощью процедуры `writeln`.

Примечание: Пожалуйста, учтите, что код на языке Паскаль чувствителен к регистру, поэтому убедитесь, что вы используете правильный регистр для ключевых слов и идентификаторов (например, `writeln` вместо `WriteLn`).

Надеюсь, эта программа поможет вам решить задачу! Если у вас возникнут еще вопросы, не стесняйтесь задавать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос