Вопрос задан 27.04.2019 в 16:33. Предмет Информатика. Спрашивает Доскина Диана.

Написать программу на си Очень срочно!!! Задание: Дана квадратная матрица. Найти сумму четных

элементов над побочной диагональю.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Аверин Макс.

что-то типа этого:

const n = 8, m = 8;
var 
    A: array[1..n,1..m] of integer;
    i, j, sum, product: integer;
    isnotnull: boolean;
begin
    randomize;
    writeln('Случайная матрица:');
    for i:=1 to n do begin
        for j:=1 to m do begin
            A[i,j] := random(51) - 25;
            write(A[i,j]:5);
        end;
        writeln;
    end;
    sum := 0;
    for i:=1 to n do
        if A[i,n-i+1] < 0 then
            sum := sum + A[i,n-i+1];
    writeln('Сумма отрицательных элементов побочной диагонали = ', sum);
    product := 1;
    isnotnull := False;
    for i:=1 to n-1 do
        for j:=2 to n do
            if (j > i) and (A[i,j] <> 0) then begin
                isnotnull := True;
                product := product * A[i,j];
            end;
    if isnotnull
        writeln('Произведение ненулевых элементов в области выше главной диагонали = ', product)
    else
        writeln('Ненулевых элементов в области выше главной диагонали нет.', product);
    readln;
end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Решение задачи на C

Для нахождения суммы четных элементов над побочной диагональю квадратной матрицы на языке C, можно использовать следующий код:

```c #include

int main() { int n, sum = 0; printf("Введите размер квадратной матрицы: "); scanf("%d", &n); int matrix[n][n];

printf("Введите элементы матрицы:\n"); for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { scanf("%d", &matrix[i][j]); } }

for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { if (i + j < n - 1 && matrix[i][j] % 2 == 0) { sum += matrix[i][j]; } } }

printf("Сумма четных элементов над побочной диагональю: %d\n", sum);

return 0; } ```

Этот код сначала запрашивает у пользователя размер квадратной матрицы, затем заполняет матрицу элементами и вычисляет сумму четных элементов над побочной диагональю.

Объяснение кода

1. На языке C мы объявляем переменные для размера матрицы и суммы, а также саму матрицу. 2. Затем запрашиваем у пользователя ввести элементы матрицы. 3. После этого проходим по матрице, проверяя каждый элемент на четность и положение над побочной диагональю. 4. Если элемент четный и находится над побочной диагональю, то добавляем его значение к общей сумме. 5. Наконец, выводим полученную сумму.

Этот код позволяет решить задачу нахождения суммы четных элементов над побочной диагональю квадратной матрицы на языке C.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос