 
Составьте программу для вычисления площади геометрических фигур (PASCAL abc)
 0
        0
         0
        0
    Ответы на вопрос
 
        uses crt;
var a,b,c:real;
begin
write('a= ');
readln(a);
write('b= ');
readln(b);
If (a<=0)or(b<=0) then
write('Сторона не может быть отрицательной, либо равна нулю')
else
c:=a*b;
writeln('Площадь квадрата, с заданными параметрами равна - ',c);
c:=a*b/2;
writeln('Площадь прямоугольного треугольника, с заданными параметрами равна - ',c);
end.
Это лишь для квадрата и прямоугольного треугольника :-)
 0
                    0
                     0
                    0
                 
            Программа для вычисления площади геометрических фигур на языке Pascal ABC
Для вычисления площади различных геометрических фигур на языке Pascal ABC, можно использовать следующую программу:
```pascal program CalculateArea;
var choice: integer; radius, length, width, base, height: real;
begin writeln('Выберите фигуру для вычисления площади:'); writeln('1. Круг'); writeln('2. Прямоугольник'); writeln('3. Треугольник'); readln(choice);
case choice of 1: begin writeln('Введите радиус круга:'); readln(radius); writeln('Площадь круга: ', 3.14 * radius * radius); end; 2: begin writeln('Введите длину прямоугольника:'); readln(length); writeln('Введите ширину прямоугольника:'); readln(width); writeln('Площадь прямоугольника: ', length * width); end; 3: begin writeln('Введите основание треугольника:'); readln(base); writeln('Введите высоту треугольника:'); readln(height); writeln('Площадь треугольника: ', 0.5 * base * height); end; else writeln('Некорректный выбор.'); end;
readln; end. ```
В данной программе используется переменная `choice`, которая позволяет пользователю выбрать фигуру для вычисления площади. Затем, с помощью оператора `case`, программа выполняет соответствующие вычисления в зависимости от выбора пользователя.
Пример использования программы:
``` Выберите фигуру для вычисления площади: 1. Круг 2. Прямоугольник 3. Треугольник 2 Введите длину прямоугольника: 5 Введите ширину прямоугольника: 3 Площадь прямоугольника: 15 ```
Программа также проверяет некорректный выбор пользователя и выводит соответствующее сообщение.
Примечание: - Площадь круга вычисляется по формуле `S = π * r^2`, где `r` - радиус круга. - Площадь прямоугольника вычисляется по формуле `S = a * b`, где `a` и `b` - длина и ширина прямоугольника соответственно. - Площадь треугольника вычисляется по формуле `S = 0.5 * a * h`, где `a` - основание треугольника, `h` - высота треугольника.
Надеюсь, эта программа поможет вам вычислить площадь различных геометрических фигур на языке Pascal ABC!
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			