Вопрос задан 22.04.2019 в 21:01.
Предмет Информатика.
Спрашивает Шипилов Сергей.
Написать программу на языке Pascal. Занесите информацию о десяти европейских странах в массивы n
(название страны), k (численность населения), s (площадь страны). Выведите названия стран в порядке возрастания плотности их населения. Попытался сделать программу, но выводит в порядке убывания.
Ответы на вопрос
Отвечает Бородкин Никита.
Const
n: array[1..10] of string = ('Россия', 'США', 'Греция', 'КНР', 'Турция', 'Германия', 'Испания', 'Колумбия', 'Бразилия', 'Египет');
k: array[1..10] of integer = (146270033, 318614000, 10992589, 1371379000, 77695904, 80780000, 46507760, 47992000, 203260762, 87265169);
s: array[1..10] of integer = (17125187, 9519431, 131940, 9598962, 780580, 357021, 504782, 1138910, 8514877, 1001450);
var
p: array[1..10] of integer;
i, j, bi, pmin: integer;
nmin: string;
begin
for i := 1 to 10 do p[i] := k[i] div s[i];
pmin := 32767;
for j := 1 to 10 do
begin
for i := 1 to 10 do
if p[i] < pmin then
begin nmin := n[i]; pmin := p[i]; bi := i end;
write(nmin, ' ');
pmin := 32767;
p[bi]:= 32767;
end;
end.
n: array[1..10] of string = ('Россия', 'США', 'Греция', 'КНР', 'Турция', 'Германия', 'Испания', 'Колумбия', 'Бразилия', 'Египет');
k: array[1..10] of integer = (146270033, 318614000, 10992589, 1371379000, 77695904, 80780000, 46507760, 47992000, 203260762, 87265169);
s: array[1..10] of integer = (17125187, 9519431, 131940, 9598962, 780580, 357021, 504782, 1138910, 8514877, 1001450);
var
p: array[1..10] of integer;
i, j, bi, pmin: integer;
nmin: string;
begin
for i := 1 to 10 do p[i] := k[i] div s[i];
pmin := 32767;
for j := 1 to 10 do
begin
for i := 1 to 10 do
if p[i] < pmin then
begin nmin := n[i]; pmin := p[i]; bi := i end;
write(nmin, ' ');
pmin := 32767;
p[bi]:= 32767;
end;
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
