Вопрос задан 11.05.2018 в 20:57.
Предмет Информатика.
Спрашивает Попова Юля.
Нужно написать программу на delphi: вводится кол-во переменных с клавиатуры на выходе 2 числа:
сумма чисел, произведение квадратов. То есть "Введите кол-во переменных" 2 3 3 Сумма = 6 Произведение квадратов = 81Ответы на вопрос
Отвечает Трунова Эля.
Консольное приложение:
program Pr1;
{$APPTYPE CONSOLE}
var
N, a, i, s: integer;
p: double;
begin
WriteLn('Введите кол-во переменных ');
ReadLn(N);
s:=0;
p:=1;
for i:=1 to N do begin
ReadLn(a);
s:=s+a;
p:=p*a*a;
end;
WriteLn( 'Сумма = ',s);
WriteLn('Произведение квадратов = ',p);
ReadLn;
end.
Пример:
Введите кол-во переменных
5
4
6
2
7
3
Сумма = 22
Произведение квадратов = 1016064
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
