Вопрос задан 11.05.2018 в 12:34. Предмет Информатика. Спрашивает Топчанский Арсен.

Составить программу умножающую две обыкновенные дроби. Как в Pascal

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Маткурбанов Максад.

// PascalABC.NET 3.3, сборка 1542 от 05.10.2017
// Внимание! Если программа не работает, обновите версию!

uses NumLibABC;

begin
   var (num,denom):=ReadInteger2('Числитель и знаменатель 1-й дроби:');
   var f1:=Frc(num,denom);
   (num,denom):=ReadInteger2('Числитель и знаменатель 2-й дроби:');
   var f2:=Frc(num,denom);
   f1.Print; Write('* '); f2.Print; Write('= '); (f1*f2).Print
end.

Примеры
Числитель и знаменатель 1-й дроби: 4 9
Числитель и знаменатель 2-й дроби: 3 8
4/9 * 3/8 = 1/6

Числитель и знаменатель 1-й дроби: 32432424 10213133
Числитель и знаменатель 2-й дроби: 23123 12313123
32432424/10213133 * 23123/12313123 = 749934940152/125755562844359

Числитель и знаменатель 1-й дроби: 15 2
Числитель и знаменатель 2-й дроби: 8 15
15/2 * 8/15 = 4

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос