
Вопрос задан 18.04.2019 в 21:34.
Предмет Информатика.
Спрашивает Аюшиев Тумэн.
Сделать в Free Pascal. В салон красоты пришло n девушек. Каждая из них должна посетить парикмахера
и косметолога. У каждого она проводит по m часов. За какое наименьшее время k сотрудников салона красоты смогут обслужить всех девушек, если каждый сотрудник может выполнять функции как косметолога, так и парикмахера? Входные данные три натуральных числа k, m, n( все числа не больше 10 000). Исходные данные одно число – минимальное время в часах, которое требуется для обслуживания всех девушек.

Ответы на вопрос

Отвечает Тонкачева Марина.
Begin
write('n m k через пробел: ');
readln(n,m,k);
s:=2*n*m;
p:=0;
repeat
s:=s-k*2*m;
p:=p+1;
until s<=0;
p:=p*2*m;
writeln('время: ',p);
end.
n m k через пробел: 3 2 5
время: 4
n m k через пробел: 6 2 4
время: 8
write('n m k через пробел: ');
readln(n,m,k);
s:=2*n*m;
p:=0;
repeat
s:=s-k*2*m;
p:=p+1;
until s<=0;
p:=p*2*m;
writeln('время: ',p);
end.
n m k через пробел: 3 2 5
время: 4
n m k через пробел: 6 2 4
время: 8


Топ вопросов за вчера в категории Информатика

Информатика 562

Информатика 404

Информатика 31

Информатика 76

Информатика 16

Информатика 41

Информатика 31
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili