Вопрос задан 12.04.2019 в 13:37.
Предмет Информатика.
Спрашивает Зубарев Илья.
Решите в паскале. Составить программу вычисляющую силу тока в цепи r1, r2, r3, r4, r5, r6, r7, r8,
r8, r9, r10, r11, r12, r13, r14, r15, r16, r17, r18, r19, r20 соединение паралельное. Сопротивления заданы в массиве, напряжение вводится.Ответы на вопрос
        Отвечает Мусатова Маргарита.
                
     Uses crt;
const R: array[1..20] of integer =(1, 2, 3, 4, 5, 6, 7, 8, 9, 10,
11, 12, 13, 14, 15, 16, 17, 18, 19, 20);
var I:array [1..20] of real;
U,x:integer;
SUM:real;
begin
write('U='); readln(U);
for x:=1 to 20 do
begin
write('R[',x,']:',R[x],' ');
I[x]:=U/R[x];
SUM:=SUM+I[x];
writeln('I[',x,']:',I[x]:5:3);
end;
writeln('I=',SUM:5:3);
end.
                                        const R: array[1..20] of integer =(1, 2, 3, 4, 5, 6, 7, 8, 9, 10,
11, 12, 13, 14, 15, 16, 17, 18, 19, 20);
var I:array [1..20] of real;
U,x:integer;
SUM:real;
begin
write('U='); readln(U);
for x:=1 to 20 do
begin
write('R[',x,']:',R[x],' ');
I[x]:=U/R[x];
SUM:=SUM+I[x];
writeln('I[',x,']:',I[x]:5:3);
end;
writeln('I=',SUM:5:3);
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			
Математика
 - 
			
Литература
 - 
			
Алгебра
 - 
			
Русский язык
 - 
			
Геометрия
 - 
			
Английский язык
 - 
			
Химия
 - 
			
Физика
 - 
			
Биология
 - 
			
Другие предметы
 - 
			
История
 - 
			
Обществознание
 - 
			
Окружающий мир
 - 
			
География
 - 
			
Українська мова
 - 
			
Информатика
 - 
			
Українська література
 - 
			
Қазақ тiлi
 - 
			
Экономика
 - 
			
Музыка
 - 
			
Право
 - 
			
Беларуская мова
 - 
			
Французский язык
 - 
			
Немецкий язык
 - 
			
МХК
 - 
			
ОБЖ
 - 
			
Психология
 - 
			
Физкультура и спорт
 - 
			
Астрономия
 - 
			
Кыргыз тили
 - 
			
Оʻzbek tili
 
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			