Вопрос задан 11.04.2019 в 03:03.
Предмет Информатика.
Спрашивает Трифонова Виктория.
Пожалуйста помогите с Паскалем Назовем число палиндромом, если оно не меняется при перестановке его
цифр в обратном порядке. Напишите программу, которая по заданному числу K выводит количество натуральных палиндромов, не превосходящих K. Входные данные Задано единственное число K (1<=K=<100000). Выходные данные Необходимо вывести количество натуральных палиндромов, не превосходящих K. пс Функции не проходили, надо как то без нихОтветы на вопрос
Отвечает Спирин Павел.
{L-левая половинка числа, R - правая}
var count,k,m,R,L:longint;
begin
count:=0;writeln('Введите k'); readln(k);
for L:=1 to k do
begin
R:=0; m:=L;
while m>0 do
begin
R:=R*10+m mod 10;
m:=m div 10;
end;
if R=L then count:=count+1;
end;
writeln(count);
end.
var count,k,m,R,L:longint;
begin
count:=0;writeln('Введите k'); readln(k);
for L:=1 to k do
begin
R:=0; m:=L;
while m>0 do
begin
R:=R*10+m mod 10;
m:=m div 10;
end;
if R=L then count:=count+1;
end;
writeln(count);
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
