Вопрос задан 10.04.2019 в 11:25.
Предмет Информатика.
Спрашивает Копылова Алёна.
составить программу вычисления суммы цифр введенного с клавиатуры 3- х значного натурального числа
. Например для числа 128 сумма цифр 11, а для числа 345 сумма цифр12.Ответы на вопрос
Отвечает Смирнов Евгений.
Var a,N,sum:word;
begin
Read (N);
Sum:=0;
While N<>0 do
begin
a:=N mod 10;
N:=N div 10;
Sum:=sum+a;
end;
Write (sum);
end.
Или по-простому еще так:
Var a,b,c,N:word;
begin
Read (N);
a:=N mod 10;
b:=(N mod 100) div 10;
c:=N div 100;
Write (a+b+c);
end.
begin
Read (N);
Sum:=0;
While N<>0 do
begin
a:=N mod 10;
N:=N div 10;
Sum:=sum+a;
end;
Write (sum);
end.
Или по-простому еще так:
Var a,b,c,N:word;
begin
Read (N);
a:=N mod 10;
b:=(N mod 100) div 10;
c:=N div 100;
Write (a+b+c);
end.
Отвечает Павлов Александр.
Program gt;
var n,s:integer;
begin
readln(n);
s:=(n div 100)+(n div 10)mod 10+(n mod 10);
writeln(s);
end.
каждая скобка это 1 2 3 цифра соответсвенно
var n,s:integer;
begin
readln(n);
s:=(n div 100)+(n div 10)mod 10+(n mod 10);
writeln(s);
end.
каждая скобка это 1 2 3 цифра соответсвенно
Топ вопросов за вчера в категории Информатика
Информатика 47
Информатика 26
Информатика 32
Информатика 70
Информатика 43
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
