Вопрос задан 06.04.2019 в 17:50. Предмет Информатика. Спрашивает Кашина Арина.

Задача D Три числаДан массив из N целых чисел а1, а2, ..., an. Вам нужно проверить, есть ли в этом

массиве три числа сумма которых равна нулю.Формат входных данныхВ первой строке входного файла содержится одно целое число N (1 ≤ N ≤ 2000). Во второй строке находятся N целых чисел a1, a2, ..., aN ( - 1000 ≤ ai ≤ 1000) — элементы массива.Формат выходных данныхВ единственной строке выходного файла выведите одно слово «YES», если в этом массиве есть три числа сумма которых равна нулю. Иначе, выведите «NO».c++ надо решать!!!!
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Смирнова Ульяна.
 Program esep;
var i,j,k,n,sum:integer;
 input,output:text;
a:array[1..100] of integer;
flag:boolean;
begin flag:=false;
Assign(Input,'d.in');
reset(input);
readln(input,n);
assign(output, 'd.out');
rewrite(output);
writeln('Input elements');
readln (n);
for i:=1 to n do read(a[i]);
for i:=1 to n do 
for j:=1 to n do 
for k:=1 to n do 
if (i<>j) and (j<>k) and (i<>k) then
 if a[i]+a[j]+a[k]=0
then
begin
writeln (output,'Yes');
flag:=true;
halt;
end;
if flag=false then writeln(output,'No');
close(input);
close(output);
end.
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос