Вопрос задан 06.04.2019 в 14:36.
Предмет Информатика.
Спрашивает Рубан Саша.
Напишите программу подсчитывающая количество минимальных элементов в заданном массиве
Ответы на вопрос
Отвечает Рудометов Владик.
Program glg;
var
a:array[1..10] of integer;
min, kol: integer;
begin
i := 0;
kol:=0;
min:= 100000;
while i < 10 do
begin
readln (a[i]);
if a[i] < min then min:= a[i];
end
i:=0;
while i < 10 do
if a[i] = min then kol = kol + 1;
writeln(kol);
end.
Если ошибки будут, пишите в комментарии. Я с телефона писал, мог где-нибудь, да ошибиться. (Написано на Pascal)
var
a:array[1..10] of integer;
min, kol: integer;
begin
i := 0;
kol:=0;
min:= 100000;
while i < 10 do
begin
readln (a[i]);
if a[i] < min then min:= a[i];
end
i:=0;
while i < 10 do
if a[i] = min then kol = kol + 1;
writeln(kol);
end.
Если ошибки будут, пишите в комментарии. Я с телефона писал, мог где-нибудь, да ошибиться. (Написано на Pascal)
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 25
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
