Вопрос задан 06.04.2019 в 14:20. Предмет Информатика. Спрашивает Литвинова Анастасия.

как составить программу подсчета количеству делений введённого числа на 12 пока оно не станет

меньше 10
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Соловьёв Артём.
Pascal:
var count:integer;
     n:real; 
begin
  write ('N = ');
  readln(n);
  count:=0;
  while n>=10 do
    begin
      n:=n/12;
      inc(count);
    end;
  write ('Kol-vo: ',count);
  readln;
end.

C++:
#include <iostream>
using namespace std;

int main()
{
   float n;
   int count = 0;
   cout <<"N = ";
   cin >>n;
   while (n>=10)
   {
      n/=12;
      ++count; 
   }
  cout <<"Kol-vo: " <<count <<endl;
  return 0;
}
0 0

Последние заданные вопросы в категории Информатика

Задать вопрос