Вопрос задан 06.04.2019 в 03:17.
Предмет Информатика.
Спрашивает Маевский Дима.
Срочно!!! напишите программу Составить программу для вычисления значений функции F(x) на отрезке
[a,b] с шагом h.Результат представить в виде таблицы,первый столбец которой-значение аргумента,а второй-соответствующие значения функций : F(x)=x-|cosx| (используя цикл while)Ответы на вопрос
Отвечает Каракчиева Диана.
Паскаль
Var a,b,h: double;
Begin
write('Введите a: '); read(a);
write('Введите b: '); read(b);
write('Введите h: '); read(h);
writeln('__________________________');
writeln('| x | F(x) |');
writeln('|_____|____________________|');
while a <= b do begin
writeln('|',a:5,'|', a-abs(cos(a)):20,'|');
a:= a + h;
end;
write('|_____|____________________|');
end.
С#
class Program
{
static void Main(string[] args)
{
Console.Write("Введите a: ");
double a = Convert.ToDouble(Console.ReadLine());
Console.Write("Введите b: ");
double b = Convert.ToDouble(Console.ReadLine());
Console.Write("Введите h: ");
double h = Convert.ToDouble(Console.ReadLine());
Console.WriteLine(" ____________________");
Console.WriteLine("| x | F(x) |");
Console.WriteLine("|_____|______________|");
while (a <= b)
{
Console.WriteLine("|{0,5}|{1,15:0.000000000|}", a, a-Math.Abs(Math.Cos(a)));
a += h;
}
Console.WriteLine("|_____|______________|");
Console.ReadLine();
}
}
C/C++
#include "stdafx.h"
#include "locale.h"
#include "stdlib.h"
#include <math.h>
#include <iostream>
using namespace std;
int main()
{
double a=0,b=0,h=0;
setlocale(0,"russian");
printf("Введите a: ");
cin >> a;
printf("Введите b: ");
cin >> b;
printf("Введите h: ");
cin >> h;
printf(" ____________________\n");
printf("| x | F(x) |\n");
printf("|_____|______________|\n");
while (a <= b)
{
printf("|%5.2f|%14.9f|\n", a, a-abs(cos(a)));
a += h;
}
printf("|_____|______________|\n");
system("pause");
}
Var a,b,h: double;
Begin
write('Введите a: '); read(a);
write('Введите b: '); read(b);
write('Введите h: '); read(h);
writeln('__________________________');
writeln('| x | F(x) |');
writeln('|_____|____________________|');
while a <= b do begin
writeln('|',a:5,'|', a-abs(cos(a)):20,'|');
a:= a + h;
end;
write('|_____|____________________|');
end.
С#
class Program
{
static void Main(string[] args)
{
Console.Write("Введите a: ");
double a = Convert.ToDouble(Console.ReadLine());
Console.Write("Введите b: ");
double b = Convert.ToDouble(Console.ReadLine());
Console.Write("Введите h: ");
double h = Convert.ToDouble(Console.ReadLine());
Console.WriteLine(" ____________________");
Console.WriteLine("| x | F(x) |");
Console.WriteLine("|_____|______________|");
while (a <= b)
{
Console.WriteLine("|{0,5}|{1,15:0.000000000|}", a, a-Math.Abs(Math.Cos(a)));
a += h;
}
Console.WriteLine("|_____|______________|");
Console.ReadLine();
}
}
C/C++
#include "stdafx.h"
#include "locale.h"
#include "stdlib.h"
#include <math.h>
#include <iostream>
using namespace std;
int main()
{
double a=0,b=0,h=0;
setlocale(0,"russian");
printf("Введите a: ");
cin >> a;
printf("Введите b: ");
cin >> b;
printf("Введите h: ");
cin >> h;
printf(" ____________________\n");
printf("| x | F(x) |\n");
printf("|_____|______________|\n");
while (a <= b)
{
printf("|%5.2f|%14.9f|\n", a, a-abs(cos(a)));
a += h;
}
printf("|_____|______________|\n");
system("pause");
}
Топ вопросов за вчера в категории Информатика
Информатика 38
Информатика 45
Информатика 24
Информатика 39
Информатика 16
Информатика 30
Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
