Вопрос задан 05.04.2019 в 19:35. Предмет Информатика. Спрашивает Beridze Ramaz.

Срочно!!! На языке pythone3.6.4 1)Входные данные Вводятся целые числа a и b. Гарантируется, что a

не превосходит b. Выходные данные Выведите все числа на отрезке от a до b, являющиеся полными квадратами. Если таких чисел нет, то ничего выводить не нужно. 2)Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x 3)Входные данные Вводятся 100 чисел, сумму которых необходимо посчитать. Выходные данные Программа должна вывести единственное число - полученную сумму.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Лебедева Анастасия.
1.
a=int(input('a: '))
b=int(input('b: '))

for i in range(a,b):
   i**=0.5
   s=i//1
   if i==s:
       print(i**2,end=' ')

2.
x=int(input('x: '));
for i in range(x):
    if x%i==0:
        print(i,end=' ')

3.
a=[]
for i in range(100):
   a.append(int(input()))
print(sum(a))

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос