Вопрос задан 04.04.2019 в 16:24.
Предмет Информатика.
Спрашивает Чепкасов Денис.
Напишите программу в паскале. Грузовой автомобиль выехал из одного города в другой со скоростью v1
км/ч Через t ч в этом же направлении выехал легковой автомобиль со скоростью v2 км/ч. составить программу,определяющею,догонит легковой автомобиль грузовой через t1 х после своего выездаОтветы на вопрос
Отвечает Кушнір Володя.
const
v1 = 5; //Скорость грузовика
v2 = 10;//Скорость легкового автомобиля
t = 5; //Задержка между выездом
var
t1 : integer; //Время, от выезда легкового авто
begin
readln (t1);
if v1 * (t +t1) <= v2 * t1 then
writeln ('Догонит')
else writeln ('Не догонит');
end.
{ Уравнение зависимости координаты от времени
x = xo + vt
x0 = 0
xg(t) = v1*(t+t1)
xl(t) = v2*t1
xl(t) >= xg(t) }
v1 = 5; //Скорость грузовика
v2 = 10;//Скорость легкового автомобиля
t = 5; //Задержка между выездом
var
t1 : integer; //Время, от выезда легкового авто
begin
readln (t1);
if v1 * (t +t1) <= v2 * t1 then
writeln ('Догонит')
else writeln ('Не догонит');
end.
{ Уравнение зависимости координаты от времени
x = xo + vt
x0 = 0
xg(t) = v1*(t+t1)
xl(t) = v2*t1
xl(t) >= xg(t) }
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 21
Информатика 267
Информатика 36
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
