Вопрос задан 03.04.2019 в 06:47.
Предмет Информатика.
Спрашивает Ковалева Анастасия.
составить программувысота сосны в начале года 1.8 м, а к концу года она увеличилась на 15%. какая
будет высота через "n" лет, если ее прирост за каждый следующий год= 90 % от прироста предыдущегоспасибоОтветы на вопрос
Отвечает Болотнова Анастасия.
Написано на Pascal:
Program Sosna;
Var a, b: Real;
n, i: Integer;
Begin
a := 1.8;
Write('n = ');
ReadLn(n);
b := a * 0.15;
a := a + b;
For i := 1 To n Do
Begin
b := b * 0.9;
a := a + b;
End;
WriteLn('Высота сосны через ', n,' лет будет ', a:10:2, ' м.');
ReadLn;
End.
Program Sosna;
Var a, b: Real;
n, i: Integer;
Begin
a := 1.8;
Write('n = ');
ReadLn(n);
b := a * 0.15;
a := a + b;
For i := 1 To n Do
Begin
b := b * 0.9;
a := a + b;
End;
WriteLn('Высота сосны через ', n,' лет будет ', a:10:2, ' м.');
ReadLn;
End.
Отвечает Носков Алексей.
Program first;
var a,b:real; n:integer;
begin
readln(n);
if n=0 then begin
writeln('Сосна почти не выросла за этот промежуток времени');
exit;
a:=1,8;
b:=(1,8*15)/100;
for i:=1 to n-1 do
b:=b+((b*90)/100);
writeln('Висота сосны через ',n,' лет равна', a+b);
end.
var a,b:real; n:integer;
begin
readln(n);
if n=0 then begin
writeln('Сосна почти не выросла за этот промежуток времени');
exit;
a:=1,8;
b:=(1,8*15)/100;
for i:=1 to n-1 do
b:=b+((b*90)/100);
writeln('Висота сосны через ',n,' лет равна', a+b);
end.
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 266
Информатика 25
Информатика 33
Информатика 16
Информатика 10
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
