Вопрос задан 07.05.2018 в 18:04.
Предмет Информатика.
Спрашивает Кирюхина Лиза.
1 Дано слово ,,КОМПЬЮТЕР". Составить программу получения слов ,,КОМ", ,, РЕТРО'', ,, РОК",
используя только буквы исходного слова. 2 Задана исходная строка ,,КОМПЬЮТЕР''. Поменять местами i и последний символ строки. Номер i задаётся пользователем . 3 Составить программу шифрования слова ,,ПАР", используя шифр Цезаря (со сдвигом на 4 позиции). составить в ПаскалеОтветы на вопрос
Отвечает Степаненко Артур.
*** 1 ***
// PascalABC.NET 3.1, сборка 1267 от 10.07.2016
begin
var w:='КОМПЬЮТЕР';
Writeln(w[1:4]);
Writeln((w.Right(3).Inverse)+w[w.Length]+w[2]);
Writeln(w[w.Length]+w[2::-1])
end.
Результат
КОМ
РЕТРО
РОК
*** 2 ***
// PascalABC.NET 3.1, сборка 1267 от 10.07.2016
begin
var w:='КОМПЬЮТЕР';
var i:=ReadInteger('i=');
Swap(w[i],w[w.Length]);
Writeln(w)
end.
Тестовое решение
i= 5
КОМПРЮТЕЬ
*** 3 ***
// PascalABC.NET 3.1, сборка 1267 от 10.07.2016
begin
var w:='ПАР'; // исходное слово
var k:=4; // константа сдвига шифра Цезаря
var a:='АБВГДЕЖЗИЙКЛМНОПРСТУФХЦЧШЩЪЫЬЭЮЯАБВГ';
for var i:=1 to w.Length do begin
var p:=Pos(w[i],a);
if p>0 then w[i]:=a[p+k]
end;
Writeln(w)
end.
Результат
УДФ
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
