Вопрос задан 01.04.2019 в 08:52.
Предмет Информатика.
Спрашивает Шульцева Ульяна.
составить программу которая будет находить сумму отрицательных чётных элементов одномерного
массива. используя процедурыОтветы на вопрос
Отвечает Саакян Аня.
Var
i,s:integer;
a:array[1..10]of integer;
procedure sum(a:integer; var s:integer);
begin
if (a mod 2=0) and (a<0) then
s:=s+a
end;
begin
write('Массив: ');
for i:=1 to 10 do
begin
a[i]:=random(-10,10);
write(a[i],' ');
sum(a[i],s)
end;
writeln;
writeln('s=',s)
end.
i,s:integer;
a:array[1..10]of integer;
procedure sum(a:integer; var s:integer);
begin
if (a mod 2=0) and (a<0) then
s:=s+a
end;
begin
write('Массив: ');
for i:=1 to 10 do
begin
a[i]:=random(-10,10);
write(a[i],' ');
sum(a[i],s)
end;
writeln;
writeln('s=',s)
end.
Топ вопросов за вчера в категории Информатика
Информатика 47
Информатика 26
Информатика 32
Информатика 70
Информатика 43
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
