Вопрос задан 31.03.2019 в 03:40.
Предмет Информатика.
Спрашивает Сидорова Юлия.
Написать программу, которая выводит пример на вычитание (в пределах 100), запрашивает ответ
пользователя, проверяет ответ и выводит сообщение "Правильно!" или "Вы ошиблись" и правильный результатОтветы на вопрос
Отвечает Тимербаева Камилла.
program ProgramXY;
const n=100;
var inputText : integer;
begin Randomize;
var x := Random(n) + 1;
var y := Random(n) + 1;
var z := x - y;
writeln('Решите пример: ', x, ' - ', y, ' = ');
readln(inputText);
if inputText = z then writeln('Правильно!')
else writeln('Вы ошиблись! Правильный ответ: ', z)
end.
Где-то так это выглядит на Паскале. Ошибки не обработаны, так что, если вместо числа ввести строку - программа умрет по исключению.
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 25
Информатика 33
Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
