Вопрос задан 30.03.2019 в 17:01.
Предмет Информатика.
Спрашивает Zurey Toma.
Составить программу вычисления суммы всех натуральных чисел меньше 100 и кратных b ( от1 до 100).
Нужно составить 1- с циклом с пред условием, 2 - с циклом с пост условиемОтветы на вопрос
Отвечает Карпов Андрей.
1)
var sum:integer;
a,b:integer;
begin
a:=1;
readln(b);
for a:=1 to 99 do begin
if a mod b = 0 then
sum:=sum+a;
end;
writeln(sum);
end.
2)
var sum:integer;
a,b:integer;
begin
a:=1;
readln(b);
repeat
if a mod b = 0 then
sum:=sum+a;
inc(a);
until a=100
writeln(sum);
end.
var sum:integer;
a,b:integer;
begin
a:=1;
readln(b);
for a:=1 to 99 do begin
if a mod b = 0 then
sum:=sum+a;
end;
writeln(sum);
end.
2)
var sum:integer;
a,b:integer;
begin
a:=1;
readln(b);
repeat
if a mod b = 0 then
sum:=sum+a;
inc(a);
until a=100
writeln(sum);
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
