Вопрос задан 30.03.2019 в 09:00.
Предмет Информатика.
Спрашивает Бурцева Елизавета.
Написать программу, проверяющую, является ли введённое значение факториалом некоторого числа на C#
Ответы на вопрос
Отвечает Кримський Макс.
Using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
namespace ConsoleApplication1{
class Program {
static void Main(string[] args) {
System.Console.WriteLine("Введите число");
int x = Int32.Parse(System.Console.ReadLine());
int p = 1;
int N = 1;
if (x == 1) {
System.Console.WriteLine("число {0} является фактриалом числа 0", x); }
while (p < x) {
N = N + 1;
p = p * N;
}
if (p == x) {
System.Console.WriteLine("число {0} является фактриалом числа {1}", x, N);
} else {
System.Console.WriteLine("число {0} не является фактриалом числа", x); }
System.Console.Read();
}
}
}
using System.Collections.Generic;
using System.Linq;
using System.Text;
namespace ConsoleApplication1{
class Program {
static void Main(string[] args) {
System.Console.WriteLine("Введите число");
int x = Int32.Parse(System.Console.ReadLine());
int p = 1;
int N = 1;
if (x == 1) {
System.Console.WriteLine("число {0} является фактриалом числа 0", x); }
while (p < x) {
N = N + 1;
p = p * N;
}
if (p == x) {
System.Console.WriteLine("число {0} является фактриалом числа {1}", x, N);
} else {
System.Console.WriteLine("число {0} не является фактриалом числа", x); }
System.Console.Read();
}
}
}
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
