Вопрос задан 29.03.2019 в 06:57.
Предмет Информатика.
Спрашивает Лупорёв Кирилл.
Напишите программу на языке Паскаль которая выводит порядковый номер минимального элемента в
двухмерном массивеОтветы на вопрос
Отвечает Фролкина Дарина.
//Pascal ABC.NET v3.0 сборка 1111
Const
n=10;
Var
ma:array[1..n,1..n] of integer;
min,mini,minj,i,j:integer;
begin
min:=2147483647;
randomize;
writeln('Matrix:');
for i:=1 to n do
begin;
writeln;
for j:=1 to n do
begin;
ma[i,j]:=random(300);
write(ma[i,j]:4);
if min>ma[i,j] then
begin;
min:=ma[i,j];
mini:=i;
minj:=j;
end;
end;
end;
writeln;
write('Строка:',mini,' столбец:',minj);
end.
Const
n=10;
Var
ma:array[1..n,1..n] of integer;
min,mini,minj,i,j:integer;
begin
min:=2147483647;
randomize;
writeln('Matrix:');
for i:=1 to n do
begin;
writeln;
for j:=1 to n do
begin;
ma[i,j]:=random(300);
write(ma[i,j]:4);
if min>ma[i,j] then
begin;
min:=ma[i,j];
mini:=i;
minj:=j;
end;
end;
end;
writeln;
write('Строка:',mini,' столбец:',minj);
end.
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 312
Информатика 23
Информатика 18
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
