Вопрос задан 29.03.2019 в 02:39.
Предмет Информатика.
Спрашивает Просикова Алина.
1)(паскаль) Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые
значения от 0 до 100 – баллы учащихся выпускного класса за итоговый тест по информатике. Напишите программу, которая находит и выводит номера двух соседних элементов массива, сумма которых минимальна. Исходные данные объявлены так, как показано ниже. Запрещается использовать переменные, не описанные ниже, но разрешается не использовать часть из них.const N=30;var a: array [1..N] of integer; i, j, min, min2, s: integer;beginfor i:=1 to N do readln(a[i]); ...end.Ответы на вопрос
Отвечает Спиридонова Анна.
Использовал две переменные из пяти возможных.
const N=30;
var a: array [1..N] of integer;
i,j:integer;
begin
for i:=1 to N do read(a[i]);
j:=1;
for i:=1 to N-1 do if a[i]+a[i+1]<a[j]+a[j+1] then j:=i;
write(j,' ',j+1)
end.
const N=30;
var a: array [1..N] of integer;
i,j:integer;
begin
for i:=1 to N do read(a[i]);
j:=1;
for i:=1 to N-1 do if a[i]+a[i+1]<a[j]+a[j+1] then j:=i;
write(j,' ',j+1)
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
