Вопрос задан 28.03.2019 в 13:14.
Предмет Информатика.
Спрашивает Валеева Анна.
Помогите срочно!!! Надо написать программу которая определяет принадлежность точки с координатами
x,y в заштрихованной области
Ответы на вопрос
Отвечает Ибрагимова Динара.
Var
prin: boolean;
x, y: integer;
begin
readln(x);
readln(y);
if (x <= 0) and (x >= -3) and (y <= x + 3) then
prin := true
else if (x >= 0) and (x <= 3) and (y <= - x + 3) then
prin := true
else if (y <= 0) and (y >= -3) and (abs(x) <= 3) then
prin := true
else
prin := false;
if prin then writeln('принадлежит') else writeln('не принадлежит');
end.
prin: boolean;
x, y: integer;
begin
readln(x);
readln(y);
if (x <= 0) and (x >= -3) and (y <= x + 3) then
prin := true
else if (x >= 0) and (x <= 3) and (y <= - x + 3) then
prin := true
else if (y <= 0) and (y >= -3) and (abs(x) <= 3) then
prin := true
else
prin := false;
if prin then writeln('принадлежит') else writeln('не принадлежит');
end.
Топ вопросов за вчера в категории Информатика
Информатика 47
Информатика 26
Информатика 32
Информатика 70
Информатика 43
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
