Вопрос задан 28.03.2019 в 05:53.
Предмет Информатика.
Спрашивает Забелич Полина.
Напишите программу ( в паскале авс), которая вычисляет число пи с заданной пользователем точностью.
Воспользуйтесь данными и условием предыдущей задачи. (условие предыдущей задачи: Напишите программу, которая вычисляет частичную сумму ряда 1-1/3+1/5-1/7+1/9-... и сравнивает полученное значение с пи/4).Ответы на вопрос
Отвечает Колосов Коля.
Var s,sgn,eps: real;
i: integer;
begin
write('точность вычислений: ');
readln(eps);
s:=1; sgn:= -1;
i:=3;
repeat
s:=s+sgn/ i;
sgn:= - sgn;
i:=i+2;
until 8/i<eps;
writeln('число пи: ',s*4);
writeln('точное значение пи: ',pi);
end.
точность вычислений: 1.0e-6
число пи: 3.14159240358966
точное значение пи: 3.14159265358979
i: integer;
begin
write('точность вычислений: ');
readln(eps);
s:=1; sgn:= -1;
i:=3;
repeat
s:=s+sgn/ i;
sgn:= - sgn;
i:=i+2;
until 8/i<eps;
writeln('число пи: ',s*4);
writeln('точное значение пи: ',pi);
end.
точность вычислений: 1.0e-6
число пи: 3.14159240358966
точное значение пи: 3.14159265358979
Топ вопросов за вчера в категории Информатика
Информатика 31
Информатика 36
Информатика 24
Информатика 43
Информатика 18
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
