Вопрос задан 26.03.2019 в 06:55. Предмет Информатика. Спрашивает Телипко Карина.

Составьте программу подсчёта числа различных элементов одномерного массива A(Q),не принадлежащих

диапозону чисел [R,P]Желательно с блок схемой Пожалуйста очень надо
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Почепець Алiна.
Var
a:array[1..20] of integer;
i,r,p,q,s:integer;
begin
s:=0;
writeln('vvedite kolichestvo elementov massiva-Q');
readln(q);
writeln('vvedite R');
readln(r);
writeln('vvedite P');
readln(p);
if (p<r) or (p=r) then
begin
writeln('neverniy otrezok [R,P]');
exit;
end else
for i:=1 to q do
begin
writeln('vvedite ',i,'-y element massiva');
readln(a[i]);
if (a[i]>=r) and (a[i]<=p) then s:=s+1;
end;
writeln('kollichestvo chisel<',r,' no >',p,' =',s);
readln;
end.
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос