Вопрос задан 24.03.2019 в 03:50.
Предмет Информатика.
Спрашивает Куликова Сонечка.
Помогите c С#! Напишите программу, вычисляющую факториал от 2 до 13.
Ответы на вопрос
Отвечает Мирова Софья.
Using System;
class Program
{
public static void Main()
{
long f = 1;
for (int i = 2; i <= 13; i++)
{
f = f*i;
Console.WriteLine("{0}! = {1}", i, f);
}
Console.ReadKey();
}
}
Результат:
2! = 2
3! = 6
4! = 24
5! = 120
6! = 720
7! = 5040
8! = 40320
9! = 362880
10! = 3628800
11! = 39916800
12! = 479001600
13! = 6227020800
class Program
{
public static void Main()
{
long f = 1;
for (int i = 2; i <= 13; i++)
{
f = f*i;
Console.WriteLine("{0}! = {1}", i, f);
}
Console.ReadKey();
}
}
Результат:
2! = 2
3! = 6
4! = 24
5! = 120
6! = 720
7! = 5040
8! = 40320
9! = 362880
10! = 3628800
11! = 39916800
12! = 479001600
13! = 6227020800
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 34
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
